5

Since I installed Freya on my PC every screenshot I take using 'print screen' key is black. I also tried using 'import' command with different options, but it only made opened windows visible on the images and my desktop was black. I had the newest AMD drivers installed from AMD website. My graphics card is Radeon R7 250x. The only solution I found on the internet was to upgrade kernel to new version and install AMD open source drivers and I updated kernel to 3.17 and installed the drivers, but it didn't help. I tried upgrading to kernel 4.0 and 4.1, but then I got black screen after boot. So now I'm using kernel 3.17 and AMD open source drivers and I still have this issue - all my screenshots appear black.

PS My display is not recognized by the system. Could this be the cause?

1
  • Same problem with AMD A8-4500M and fglrx
    – Suici Doga
    Apr 23, 2016 at 5:55

2 Answers 2

3

First, press Ctrl + Alt + F2, then press Ctrl + Alt + F7 and then take a screenshot.

1
  • 2
    I don't know why this answer is being down-voted, since it is a valid workaround for the problem.
    – lf_araujo
    Jan 5, 2016 at 23:09
2
+50

This is a typical problem for AMD proprietary drivers. For it can not affect anybody, except AMD. Only one way out - use default free driver.

3
  • When do we need the AMD proprietary driver? Is there any different when we are using it?
    – JulianLai
    Jan 9, 2016 at 4:55
  • 1
    @JulianLai Less power consumption , better performance and no overheating
    – Suici Doga
    Mar 18, 2016 at 2:08
  • The free driver is very good in kernel 4.4 and 4.5 . I am going to try it since fglrx has lots of problems
    – Suici Doga
    Apr 23, 2016 at 5:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.