0

I've just set up the nvidia-375 package (also nvidia-settings, nvidia-prime, and nvidia-opencl-icd-375) on my new Elementary OS installation. I was hoping it'd work after a simple reboot, as it has in the past, but a few irregular things happened and now it won't work:

During installation, it asked me to disable Secure Boot in order to make the drivers work. I chose no, as I've never had to do that before (though, I was in BIOS/legacy mode before,) but later used dpkg-reconfigure to choose Yes instead. It didn't fix any of my problems.

prime-select queryreturnsunknown` unless I have explicitly selected an option during the current session.

While I have prime-select set to unknown or nvidia, it tells me:

name of display: :0
Error: couldn't find RGB GLX visual or fbconfig

When running sudo prime-select nvidia, I get the following output:

Info: the current GL alternatives in use are: ['nvidia-375-prime', 'nvidia-375-prime']
Info: the current EGL alternatives in use are: ['nvidia-375-prime', 'nvidia-375-prime']
Info: selecting nvidia-375 for the nvidia profile
update-alternatives: using /usr/lib/nvidia-375/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

update-alternatives: using /usr/lib/nvidia-375/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf (x86_64-linux-gnu_egl_conf) in manual mode
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

update-alternatives: using /usr/lib/nvidia-375/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

update-alternatives: using /usr/lib/nvidia-375/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf (i386-linux-gnu_egl_conf) in manual mode
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

I get similar messages about nvidia's libEGL when switching back to intel, too.

  • Output from "cat /proc/acpi/bbswitch"? – Атанас Минков Sep 3 '17 at 22:31
  • @АтанасМинков None, it doesn't exist. I'm not using Bumblebee, I'm trying to just straight-up use the NVIDIA card. – Ethan McTague Sep 3 '17 at 23:41
  • I thought you have Optimus setup, because you mentioned prime-select. And it doesn't work without bbswitch, no matter using or not bumblebee. – Атанас Минков Sep 4 '17 at 14:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.