0

When I try to start Steam, it just starts and closes for some reason. I use Elementary OS Loki. I installed steam using sudo apt install steam the output in the console when I tried to run it in terminal is

Running Steam on elementary 0.4.1 64-bit STEAM_RUNTIME is enabled automatically Pins up-to-date! [2017-09-03 14:16:19] Startup - updater built Aug 28 2017 11:50:29 Looks like steam didn't shutdown cleanly, scheduling immediate update check [2017-09-03 14:16:19] Checking for update on startup [2017-09-03 14:16:19] Checking for available updates... [2017-09-03 14:16:19] Download skipped: /client/steam_client_ubuntu12 version 1503954609, installed version 1503954609 [2017-09-03 14:16:19] Nothing to do [2017-09-03 14:16:19] Verifying installation... [2017-09-03 14:16:19] Performing checksum verification of executable files [2017-09-03 14:16:20] Verification complete

PLS HELP!!!

The video of what happens is: https://youtu.be/C35hWGzdD0s

  • try uninstalling steam: "sudo apt-get purge steam" then delete the .steam folder in your home folder. After that install Steam using the appcenter. Installing Steam from apt seems to not work in my experience. – Eosdude Sep 9 '17 at 14:39
  • Except there is no Steam available to download or install, either via appcenter, or via apt. – Callista Graves Nov 25 '17 at 1:31
-1

If you still have some problems installing Steam try to do it through the installation package from the website of poweredsteam.com

Download the .deb package and use the command below to install it:

sudo dpkg - i steam*

It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.