Just installed EOS on my laptop. First issue is that when it asks me to reboot to finish installation the reboot button is greyed out. After waiting about 10 minutes I just hard reset the laptop. After boot I get the login screen. I log in and the login screen disappears and the desktop never appears. Any ideas?

Laptop is msi gs63vr. Elementary os has worked on this laptop in the past.

  • I don't know if my problem is relevant to yours, but sometimes my desktop doesn't start fully (ie. dock, wingpanel, startup applications) when I'm on two-monitor setup. (Today it took me three tries for it to boot properly.) No problem when booting with single monitor. Sep 4, 2017 at 8:55

2 Answers 2


Try renaming at-spi-dbus-bus.desktop:

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled

I think you're running into this bug:


I had a similar issue and this fixed it for me. You might have to boot into recovery mode to access the terminal.


OK well this is silly and possibly entirely my own dumb fault. After clicking restart after the installation I didn't give it enough time. I let it sit at the grayed out restart button for about 5 minutes and that wasn't enough. This time I waited until it dropped to a command line, spit out some stuff, and when it seemed to be done (no real indication) I shut the laptop down with the power button. Booted it up and it launched fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.