0

I am trying to install the MFC9130CW printer that I have on my wireless network. FOllowing the instructions on the brother website, I have installed the necessary drivers via their deb files. However, I still cannot print. It should not be a network error, as all other computers in the house are able to print (running other OS's).

In so far, I have tried various combinations of connections (i.e. socket, ipp, ipps, etc.), but to know avail. Maybe I am doing it wrong? I am running the latest version of ElementaryOS. The printer is on 192.168.1.23 on my local network. Please let me know what I should try to get this thing working! I'll start all over if need be. It is driving me crazy.

Thanks! ~Lucian

1

This is how it works with scan machine from Brother (all-in-one). Maybe you should just replace scan command to print command? And of course need to replace IP adres and name of machine.

Download and install those packages : brscan4, brscan-skey and brother-udev-rule. Check if you Brother model is available to configure - run command in terminal:

brsaneconfig4 -q

If you Brother model is on the list after perform previous step, then you can configure it:

brsaneconfig4 -a name=DCPJ152W model=DCP-J152W ip=192.168.1.102

Test if your Brother printer is available through the network:

brsaneconfig4 -p

If your device is responding, you can go to the next step. Finally use tools like XSane or VueScan to scan your docs using Brother scanner.

1

Strange, I have a CDW 9330 printer and it works well. Scanning does not. I gave up on that. So, I can understand the madness. Please breathe deeply and try again.

First, test if you can reach the printer from your eOS machine by pinging it. Printing over WLAN is notoriously unreliable in our house. There really are differences between devices.To rule this out, connect your computer via Ethernet.

Next, try to remove the drivers you installed.

Use the network printer install option in eOS. It worked for me.

If that still does not work, you will have to dive into cups, which should be installed on your machine. If not get it from cups.org

CUPS has a web interface. See: http://localhost:631

Once you get here, you can be sure you will get your printer working. CUPS is that good.

Go to the Administration Tab under Printers and click Manage Printers to see what is currently installed. If empty, add your printer and test it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.