4

Whenever I do sudo apt update, I get the following response:

Ign:1 http://ppa.launchpad.net/elementary-os/stable/ubuntu loki InRelease
Hit:2 http://in.archive.ubuntu.com/ubuntu xenial InRelease                                                                                      
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                                                                               
Ign:4 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu loki InRelease                                                                                            
Get:5 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                                                
Ign:6 http://http.kali.org/kali loki InRelease                                                                                       
Ign:7 http://security.kali.org/kali-security loki InRelease                                                                          
Err:8 http://ppa.launchpad.net/elementary-os/stable/ubuntu loki Release                                         
  404  Not Found
Err:9 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu loki Release                                     
  404  Not Found
Err:10 http://http.kali.org/kali loki Release                                                                   
  404  Not Found
Err:11 http://security.kali.org/kali-security loki Release                                              
  404  Not Found
Get:12 http://in.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]    
Reading package lists... Done      
E: The repository 'http://ppa.launchpad.net/elementary-os/stable/ubuntu loki Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/elementary-os/os-patches/ubuntu loki Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://http.kali.org/kali loki Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.kali.org/kali-security loki Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I'm able to do sudo apt upgrade and everything seems to work fine but this bugs me a lot.

I found similar questions in the forum but nothing with this exact issue.

I thought this answer would solve the issue for me but there are no ubuntu/dists/loki in my /etc/apt/sources.list to replace with ubuntu/dists/xenial.

How can this be resolved?

4

Right click on the Files icon in Plank dock, select New Window As Administrator, go to /etc/apt/sources.list.d/ folder and edit the various files there related to each of the errors by changing references from loki release to xenial release.

Otherwise, delete the kali repository file, because there isn't a loki or xenial release for it. Kali is a Debian based distro.

Then try again with

sudo apt update 

Update in relation with similar occurrences:

This might be related to more than just this bug. I have seen a similar error in third party ppa-s where instead of "xenial" was written "bionic" resulting in a similar error with ha similar fix.

  • 1
    You're welcome Bilesh Ganguly – bitseater Aug 22 '17 at 18:07
3

I do not have enough rep to comment on answers. So here it goes. That oneliner does the trick for you or anyone in same situation

find /etc/apt/sources.list.d/ -type f -exec sed -i.bak -e 's/loki/xenial/' '{}' \;
0

@bitseater's answer should fix the issue, but to get to the bottom of this issue I would recommend people experiencing this issue to help out in the following issue: https://github.com/elementary/appcenter/issues/565 More information on what might have caused the issue would be very welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.