I installed the newest version of elementary OS recently on my Thinkpad Carbon second generation. The OS works fine. The only thing is that the computer is not shutting down when asked to. If you choose shut down the device is only logging out. If I want to shut the computer down I have to force the shutdown via the power button. I already did update and upgrade the Ubuntu drivers with no effect.

  • i do have a similar kind of experience, need to force restart or shutdown most of the time. when i shutdown the system normally it stuck at the elementary logo. not sure why its happening maybe some process not quiting in time or something like that. Aug 11, 2017 at 13:23
  • What happens for both of you if you enter: sudo shutdown -h now in terminal?
    – Eric G
    Aug 14, 2017 at 14:33
  • Did you try to kill cerbere before shutdown?
    – ubgus
    Jan 19, 2020 at 16:14

1 Answer 1


In my case sudo shutdown -h nowwould hang too. I also tried changing the grub configuration as suggested in many posts, but still had the same result.

Boot into recovery mode by pressing the shift key at boot. From there go to 'Advanced Options. There is an option to run fsck to repair your disk. For good measure also perform the check grub option. After that, select reboot normally from the menu. The system will reboot and then should shutdown normally.

  • 1
    When the computer is shutting down if you press the up arrow key you can see what the computer is doing. My setup used to hang for a while on some networks shutting down the CUPS printer service, to ensure there were no unfinished print jobs. That has been fixed now, but perhaps you can have a look at the text shown during shutdown, and let us know what it is getting stuck on. Nov 1, 2017 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.