1

I'm having a problem with the sound on Loki.

I can tell you that is not a hardware malfunction, because in Windows 10, the speakers sound amazing.

Thing is, with headphones, the sound is excellent. The problem is with the speakers. With the speakers the sound is HORRIBLE.

lspci | grep -i audio

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 02)

Thanks in advance!

3

First ensure you have Allow louder than 100% unchecked in the sound settings, as peaking audio is generally the cause of terrible audio quality, and can damage speakers sometimes.

Second, you can try editing your deamon config file (although back it up it first): Local version: ~/.config/pulse/daemon.conf System wide version: sudo nano /etc/pulse/daemon.conf

You will probably not have a local version so you can cp /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf first and then try and edit it.

Here are some possible changes (suggested here):

default-sample-format = float32le
default-sample-rate = 48000
alternate-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right

default-fragments = 2
default-fragment-size-msec = 125
resample-method = soxr-vhq
enable-lfe-remixing = no
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 9
daemonize = no

Now to test new settings:

pulseaudio -k
pulseaudio -D

Hope that helps!

  • I tried this and it works great! Thank you!!! – Sean Patterson Aug 10 '17 at 22:40
0

In sound settings simply switch Mode

  • Which mode do you suggest? – bigbang Aug 21 '18 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.