0

I installed elementary os loki recently. There was a problem that the wifi kept asking for password again and again. I run a terminal command to disable 802.11n. The command solved that problem but later the wifi kept losing the internet connection if i did not use it for just 10 sec. If I download something then it is working perfectly but while browsing if I pause on a page, it loses internet connection and then I have to restart the wifi. The main problem is that I reinstalled elementary but that too did not solve this problem. Thanks in advance. My wifi adaptor is BCM43142.

iwconfig wlo1 IEEE 802.11 ESSID:"TP-LINK_806A" Mode:Managed Frequency:2.437 GHz Access Point: EC:08:6B:F6:80:6A Retry short limit:7 RTS thr:off Fragment thr:off Power Management:off lo no wireless extensions. enp2s0 no wireless extensions.

  • Please edit the question to include results for iwconfig – Jeremy31 Aug 7 '17 at 17:29
  • Do the results change when you get disconnected? – Jeremy31 Aug 7 '17 at 19:31
  • No they are the same – Surya Kant Bansal Aug 8 '17 at 2:10
1

What it sounds like is that your router(not your adapter) has an idle timeout, with the time set to a very low number. Assuming you have access, you could either find out if it's set that way through the router's Web interface (preferred), or do a factory reset on your router.

If you do the latter, make sure you record all of your settings, and if it's a company router, get IT involved, because no changes since the router was NIB will be saved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.