1

Firstly thank you to everybody that contributes to Elementary OS, what a great product.

Please help, I have limited bandwidth which is costly where I am. I have tried numerous ways of disabling the automatic background downloading of updates:

  • I've uninstalled the unattended-upgrades package and Appcenter
  • I've removed all the files that seem to be related to Apt from the /etc/cron.daily | .weekly and .monthly folders.
  • I've removed /usr/lib/apt/apt.systemd.daily
  • I've run: systemctl stop apt-daily.timer systemctl disable apt-daily.timer systemctl daemon-reload

Still when I run apt upgrade I notice that package updates have been downloaded, they are not installed, but the "Need to get xx MB/xxx MB of archives" message reflects that the archives are being downloaded somehow in the background.

I realise that this is a good practice, but it costs me money and I need to be able to update only when convenient.

Thank you so much in advance.

-1

On Ubuntu 16.04, (on which is based Loki, so maybe it works) you could use

$ sudo systemctl mask apt-daily.service
$ sudo systemctl disable apt-daily.timer
$ sudo systemctl disable unattended-upgrades

and then update/upgrade manually when you see fit

Check more here: https://www.hiroom2.com/2016/05/18/ubuntu-16-04-auto-apt-update-and-apt-upgrade/

  • So this will stop all updates unless done manually? Will it also prevent update checks and notifications? – Sean Patterson Aug 7 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.