0

After running the updates today I think appcentre said there were 8 updates, it seemed to hang the process while running 2 "operating system" updates. I waited a few hours for it to finish (5 I think) but it never did. I tried to reboot the system but it didn't respond so I (against my better wisdom) forced the appcentre closed and force rebooted. Now I can only boot into emergency mode. I'm not sure what to do now. I'm reading that I should try a live distro and try to fschk the root partition. I'm about to try that now. Anyone know what to try here, or need more info? I can't seem to get network access in emergency mode; at least I don't know how to...

  • 1
    Upon reboot I get a message, /dev/sda1: clean. A start job is running for dev-disk-by\x2duuid-9608803308801481.device with a 1minute, 30 second count down. Then it continues and boots to emergency mode. Fsck is clean. I've tried "systemctl reboot" with the same thing and journalctl -xb shows the same error as above with dev-disk-by\x2duuid-9608803308801481.device/start timed out. That disk is a network SMB drive that I mount at startup. – Andrew Aug 4 '17 at 3:14
  • 1
    OK, so I edited my fstab and commented out that entry. Issued "systemctl reboot", and after the grub menu it booted fine! So thankful... – Andrew Aug 4 '17 at 3:17
  • You can add your procedures as an answer if it solved your problem :) – Axel Advento Aug 4 '17 at 11:04
0

Commenting out the mount point listed in the error in my fstab solved my problem. I don't have a clue why this became an issue today as I've had that for many many months. Probably over a year with that setting.

| improve this answer | |
0

I had the same behaviour yesterday and thanks to Your comments I realized that the last chance I did to my machine was precisely in the fstab file.

I removed the problematic line and voyla! it worked.

here it is the procedure:

1.in the terminal showed while booting Press CTRL-D to enter emergency mode 2. enter the command vi /etc/fstab 3. move to the problematic entry with arrow keys, in vi you could remove the entire line by pressing letter D twice 4. Exit vi saving the file by pressing ESC : WQ in secuence 5. Reboot the machine with systemctl reboot

This saves Me from reinstalling everything

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.