0

I write in Polish. In the Polish default keyboard on the special Polish characters are created by pressing right alt and several letters (z,s,c etc). Since I work a lot on macs I am used to another combination LEFT ALT + the letter. On my laptop I prefer the combination window key + the letter. In any case I find it difficult to type fast using the default combination of left alt + letter. In Freya it was easy to fix this by choosing 3rd level, in Loki it became impossible. To solve the problem I use command "sudo dpkg-reconfigure keyboard-configuration" and choose the combination I need BUT I HAVE TO DO IT EVERY TIME I RESET THE COMPUTER OR START WORKING. It is maybe acceptable but quite annoying. Is there any way I could preserve the keyboard layout I reach after using the reconfigure series of options (this takes some time and becomes tedious)? I would be grateful if hopefully someone told me how they reconfigured the keyboard permanently, many thanks Marek, Poland

1

After changing your keyboard settings, do in terminal:

setxkbmap -query

You should see the options you have chosen,e.g:

    setxkbmap -query
rules:      evdev
model:      pc105
layout:     de
variant:    mac
options:    terminate:ctrl_alt_bksp

You can try setting this command:

setxkbmap -model pc105 -layout pl -option 'lv3:lwin_switch'

with your options. I'm not sure if this is going to be permanent, try it out.

If it's not permanent, there are 2 options:

  1. changing /etc/default/keyboard:

in terminal:

sudo nano /etc/default/keyboard

A text-file will be opened where you can write your input. This should be loaded upon startup.

  1. putting your command in Startup-Aplications:

Go to System-Settings->Applications and add a new Startup-Apllication with your command above, eg:

setxkbmap -model pc105 -layout pl -option 'lv3:lwin_switch'

EDIT: you can see all the possible layouts and options in this file: /usr/share/X11/xkb/rules/base.lst

  • Many thanks I shall try it out today. Most grateful ;) – Marek Aug 1 '17 at 13:11
  • No luck so far. This is my options: rules: evdev model: pc105 layout: pl options: lv3:lwin_switch – Marek Aug 1 '17 at 18:15
  • How do I use this info? There is no way to load the lv3 stuff and in every method I end up with the same problem - special characters on right alt while I would prefer them on the left alt like it is done in a mac keyboard. Please give me a hint. – Marek Aug 1 '17 at 18:17
  • I tried the nano command but cannot save the file, anyway I do not know how to implement lv3:lwin_switch, with -options it is treated as an error – Marek Aug 1 '17 at 18:18
  • @Marek Try: setxkbmap -model pc105 -layout pl -option 'lv3:lwin_switch' For the other approach: just put lv3:lwin_switch after options in the text file. You save the file with Ctrl+O and exit with Ctrl+X. (Be sure to run sudo nano /etc/default/keyboard ) – Eric G Aug 2 '17 at 5:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.