A few weeks ago i was messing around with creating a Hotspot but after testing it i didn't want to have it anymore, now every time my laptop starts it automatic login to the test Hotspot i created, i then have to open up Network Settings and disabled the Hotspot option and then my system automatically logins to my home network, This is what i want to happen at startup not to login to Hotspot. I dont see any option to remove this hotspot i created, is there anyway to remove this hotspot via the gui or command line? Any help will be appreciated.

2 Answers 2


Click on the network icon in the top bar and select Network Settings (at the bottom of the menu).

Click on the Edit Connections button at the bottom of the Network window.

In the new dialog, scroll down until you see the hotspot you created and click on it.

The Delete button should then become active, click on that and you will be asked to confirm you want to delete the connection.

After confirmation the hotspot should be removed.

  • Hi @rdanter i followed your steps and i didn't see the hotspot name, i already had looked, that's why i'm puzzled.
    – LLR
    Aug 2, 2017 at 22:53
  • Hmm, odd, what do you have in /etc/NetworkManager/system-connections/ ? Is there a file with the same name as the hotspot or one containing a line id=<hotspot name> ? If so then you can try to remove it (you will need to use sudo).
    – rdanter
    Aug 11, 2017 at 8:14

Also encountered this quirk in elementary OS 5.1.7 Hera. There is no Forget this network style option for quick removal. It has to be removed manually.

The terminal-based method, as per the follow-up comment by rdanter and the manual removal procedure in Debian is:

cd /etc/NetworkManager/system-connections/

This solves the issue in my situation as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.