4

Since two days ago, I am experiencing a difference in how one-finger movements on the touchpad are translated into cursor movement. It is less smooth than before, especially when it's just a small movement the cursor seems to resist to move, e.g. when I'm trying to hit a button or something. What could have caused that? Has there been an update to the driver? If so, how can I revert back to the previous version?

I am using an Asus Zenbook UX305U with elementary OS Loki 0.4.1

2
  • I'm pretty sure that the problem happened after libinput update. This is my apt log after this update: pastebin.com/Aq8QFpVW
    – png2378
    Commented Aug 2, 2017 at 19:01
  • 1
    I am experiencing something similar. It happens in conjunction with the upgrade to kernel 4.10. So it began for me a few days ago. I've submitted a bug report on Launchpad and have a thread on the forum here.
    – pretz
    Commented Aug 2, 2017 at 19:10

2 Answers 2

1

There is a way to downgrade HWE graphical stack to Xenial default (however, it will be maintained until 2021).

Be careful and follow these commands at your own risk!

Firstly, you should remove HWE graphical packages:

sudo apt remove xserver-xorg-core-hwe-16.04 xserver-xorg-input-all-hwe-16.04 xserver-xorg-video-all-hwe-16.04

This command will remove Xorg and elementary-desktop metapackage. In total 19 or 20 packages will be removed. Then, install older version of Xorg and reinstall elementary-desktop metapackage (don't reboot your PC before running this command!):

sudo apt install elementary-desktop xserver-xorg-core

Reboot and enjoy ;-)

6
  • Thanks for the post! Do you have a source for this solution?
    – pretz
    Commented Aug 7, 2017 at 17:14
  • I gave it a shot and it worked. Not 100%, but it certainly improved the mouse function. Then I ran "xset m 10/1 20" and it's much better. So I'm about 90% of what the touchpad was before. Not perfect, but will just take some getting used too. Thank so much!
    – pretz
    Commented Aug 7, 2017 at 22:48
  • Nevermind. After some time in suspend it now has disabled the touchpad. Reboot doesn't help. Going to try a reinstall and don't adjusting the sensitivity and acceleration settings through the terminal.
    – pretz
    Commented Aug 8, 2017 at 2:27
  • Source? There is no source.
    – png2378
    Commented Aug 8, 2017 at 18:34
  • 1
    @SeanPatterson I understood what you mean, I myself found this solution :)
    – png2378
    Commented Aug 10, 2017 at 16:36
-1

you have to delete the synaptic conf files in the /usr/share/X11 directory then reboot. update switched to libinput so the synaptic files are unneeded/hindering it.

1
  • You're going to need to give more information than that for the sake of others, such as how to delete the files and what files to delete specifically. Also, isn't this something that could be handled apt --purge packagename?
    – RolandiXor
    Commented Oct 26, 2017 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.