1

The following problem emerged after the previous software update was installed.

When I try to save something from the internet on a browser, I get a window in which I can browse my file system to choose where I save it. However, the save button is missing. As a result, I am unable to save anything from my browser. I've tried using Google Chrome, Chromium, and Firefox and have the same issue with all of them. I've currently just chosen the browser option of automatically saving things to the Downloads folder, rather than open up the window in which I can browse my files. However, I am often unable to save automatically and the file browser window shows up, in which case I cannot save. This has become very inconvenient so it's impossible for me to download some things from the browser. Any help would be appreciated.

Here is the screenshot of it. I tried to save some archive. Notice that the save button not showing.

enter image description here

closed as off-topic by Hasan Apr 25 at 5:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The Question is about a release or feature that has been significantly updated, to the point at which upgrading fixes the issue or answers the question." – Hasan
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You mention the Google browsers and Firefox, have you tried this in epiphany? – Sean Patterson Jul 27 '17 at 18:58
  • Well in Epiphany, all my downloads automatically go into the Downloads folder, so I can download whatever I want using Epiphany. However, I much prefer using Google Chrome or Firefox and the inability to choose where I save things while downloading is really inconvenient. – Amy Aug 1 '17 at 15:02
  • I am facing the same issue now. I've updated the post. – Nayab Basha Sayed Aug 11 '17 at 5:38
  • Same problem here! The Save and Cancel buttons are missing. Later edit: Installed Tweaks... elementaryos.stackexchange.com/questions/6828/… ... and now i got the buttons. Strange because I made no changes with tweaks. – redbaron Aug 13 '17 at 7:31
  • Are you using default theme or did you change anything? I'm asking because I had the same issue one week ago, when customizing my theme. – Eric G Aug 13 '17 at 13:09
1

Okay, so I solved the problem. I needed to install and build elementary-tweaks as per the instructions found in the following link: https://github.com/elementary-tweaks/elementary-tweaks

Then I went into the System Settings application, and Tweaks was listed under the Personal category. I went into Tweaks and under the Appearance setting, I switched on "Show Gnome menu".

This fixed the problem! Hope this works for you all.

Not the answer you're looking for? Browse other questions tagged or ask your own question.