I am having some problems with Dropbox. I have installed it but it doesn't open.

There also a bad icon on that top

What can I do ?

enter image description here


2 Answers 2


This is a known issue which effects several applications. To fix it edit the ~/.config/autostart/dropbox.desktop file and change the Exec line to this:

Exec=env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE="" dropbox start -i

Log out and back in and the icon should be correct. I have noticed that even with this the menu sometimes does not appear correctly, but usually a second click will work.

My complete .desktop file:

[Desktop Entry] Name=Dropbox GenericName=File Synchronizer Comment=Sync your files across computers and to the web Exec=env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE="" dropbox start -i Terminal=false Type=Application Icon=dropbox Categories=Network;FileTransfer; StartupNotify=false X-GNOME-Autostart-enabled=true

  • Thank you, but it still doesn't work. Jul 29, 2017 at 12:42
  • I have added my complete .desktop, in case I missed something. Hope it helps, it has worked for me for a long time.
    – rdanter
    Jul 29, 2017 at 21:52
  • Hey ! I have checked and it works now. Thank you very very much rdanter !! Jul 30, 2017 at 10:42
  • Could you mark the answer as correct? I need more reputation points so I can comment on other questions :)
    – rdanter
    Jul 30, 2017 at 10:53

The previous answer has worked until I restart my system. But this script is working for me permanently


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.