0

I've been using ElementaryOS for a few months since I decided it would be my daily driver.

I had no problems with it until last night when I decided to run a "apt upgrade" from terminal then rebooted the computer as I always do.

The funny thing is that the elementaryOS logo shows up, then it goes to the blinking cursor and gets stuck there forever, and if I hit CTRL + ALT + DEL, it shows the logo once again and then reboots.

I tried booting into the recovery mode and selecting the DPKG option to check for broken packages but it says "An upgrade from 'loki' to 'xenial' is not supported by this tool".

FSCK won't do anything.

I don't really know where to go from here.

Thanks in advance.

  • Do you have custom repositories aside from the default one? You probably added a repository that conflicts with the default ones and/or rebooted without verifying if the upgrade has completed without problems. If you can boot from a live distro and revert your repository files to the default ones, you can try doing the DPKG option again. – Axel Advento Jul 27 '17 at 12:25
  • What happens to your boot up sequence would be 1. Elementary logo shows up, indicating booting up 2. Blinking cursor as a symptom of problematic boot up 3. CTRL+ALT+DEL in Linux TTY would invoke reboot 3. Elementary logo shows up again indicating shutdown. You can have more info of what happens with the boot up/shutdown sequence by pressing ESC every time the Elementary logo shows up – Axel Advento Jul 27 '17 at 12:30
  • @AxelAdvento thanks for your answer. I don't believe I added any other PPAs aside from spotify. I had already tried seeing any errors with the ESC key trick but it just goes directly to the blinking cursor. Could you direct me on how to revert the repository to the default so I can try it anyway? Thanks again! – rbaker91 Jul 27 '17 at 15:31
0

I didn't find a solution to the problem so I ended up reinstalling the OS altogether.

However, the problem came back after I installed AMDGPU-PRO drivers. This time I was able to boot into recovery and do an uninstall.

On the first installation I had the drivers installed since day one, so I suspect they were compatible with that version of Loki, until I upgraded the system and the drivers became incompatible somehow.

I think I'll stick to the default drivers or use oibaf.

Thanks for all the comments.

-1

I had the same issue. It helped, when i went to the bios and turned off fast boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.