0

I have install Popcorn Time from the website and create a Desktop Entry to ~/.local/share/applications and on ~/usr/share/applications for show it on the menu.

Bue when I execute still getting and blur icon and duplicate for the one I have on dock.

[Desktop Entry]
Type = Application
Encoding=UTF-8
Name = Popcorn Time
Comment = Comment on the program
Exec = /home/kevin/popcorntime/Popcorn-Time
Icon = /home/kevin/popcorntime/src/app/images/icon.png
Terminal = false

That one says Butter

I'm thinking that maybe is there another execute because even has another name when the mouse is hovering the icon

Elementary OS Loki.

0

You need to add a StartupWMClass line to your desktop file. To identify what value to put there run in the terminal:

xprop WM_CLASS 

Then click on your Popcorn Time .desktop file copy the terminal output and place it after StartupWMClass=

Here is an example using Gnome Terminal:

StartupWMClass= "gnome-terminal", "Gnome-terminal"

  • I think I don't get it. I execute that command and click on the popcorn time application because if I click on the file just tell me "Pantheon files" And when I click on the application i get WM_CLASS(STRING) = "crx_hecfofbbdfadifpemejbbdcjmfmboohj", "Chromium-browser" and also doesn't work – ikenshu Jul 21 '17 at 17:15
  • where are you installing the app from? – Sean Patterson Jul 21 '17 at 22:29
  • from popcorn time.sh and I extracted on Home – ikenshu Jul 22 '17 at 3:14
  • 1
    I fix it now, you were right. But I need to remove the one I make in /usr/share/applications folder and put the first output of that command you give me, in this case, was "crx_hecfofbbdfadifpemejbbdcjmfmboohj". I follow this answer too. Thanks @Pretzel Jones – ikenshu Jul 22 '17 at 12:40
1

StartupWMClass is only used to group windows with the same class name. You need to look at changing the class with the exec command if the program supports gtk options.

Try running the executable with --class="Popcorn-Time". Worked for me.

See also:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.