I just installed elementary OS Freya in a partition where the old elementary OS Luna used to be, but in grub I can't see the option to boot with Freya, but the old Luna one. When selecting this one the computer restarts again.

The grub partition already existed because I have Ubuntu. I chose /dev/sda8 as the partition were elementary OS would be installed, but I wasn't really sure about this one. It's the same partition I chose for elementary to be installed.

So why is it missing in grub?

  • 1
    Have you tried updating the GRUB from your Ubuntu partition using update-grub?
    – r3bl
    Commented Aug 13, 2015 at 20:08
  • ummm nope? Would that help my situation?
    – dabadaba
    Commented Aug 13, 2015 at 20:20
  • It will make GRUB automatically refresh its list of entries and possibly fix the issue you're having. Try it and let me know how it went.
    – r3bl
    Commented Aug 13, 2015 at 20:28
  • that totally worked! thanks! I assumed with the new installation it'd be automatically included to the boot load menu
    – dabadaba
    Commented Aug 14, 2015 at 0:33
  • 1
    @r3bl you should post your solution as answer.
    – Ben
    Commented Aug 14, 2015 at 5:15

1 Answer 1


Grub currently shows the old list of operating systems installed (hence the Luna boot option instead of Freya).

To show the updated list of entries, you have to refresh GRUB from the Ubuntu installation (or a Ubuntu Live Media) with the command update-grub.

(Thanks @r3bl !)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.