2

DrRacket (both 6.8 and 6.9) when installed has issues with GUI. Racket developers suggest that the problem could be in the os side. I have attached the screen shot. The same kind of problem is for other windows in Racket IDE.

I tried changing the file GTK_CSD=1 in the file /etc/profile.d/gtk-csd.sh to GTK_CSD="" but it did not work.

DrRacket Startup Window

0

I don't know why did you used an sh package and not the PPA available who can work with the package manager you have

Just use apt

DrRacket PPA

https://download.racket-lang.org/

https://launchpad.net/~plt/+archive/ubuntu/racket


sudo add-apt-repository ppa:plt/racket

sudo apt install racket

DrRacket Main Window

| improve this answer | |
0

So, I ran into this issue recently and found a decent workaround that fixes this. It is caused due to the GTK client side decorations. Hence, we can disable it temporarily for DrRacket.

  • After installing DrRacket, open the startup script
    • In my case, I installed at /usr/bin/drracket
    • In your case, you would need to edit ~/racket/bin/drracket
  • vi /usr/bin/drracket (or) vi ~/racket/bin/drracket
  • Add this line at the head of the script
# Workaround to remove client side decoration
GTK_CSD=""
  • Save and exit. Now, open DrRacket and it should work fine.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.