4

As title says - when launching "mc" in Pantheon Terminal the F10 key (used to signal "quit" for mc) is not received.

The Gnome Terminal has the option to disable the "menu shortcut key F10".

Is there a workaround or a configuration to change?

Thank you for your help!

Best regards, SoftExpert

2 Answers 2

5

To be able to use the F10 inside the terminal edit your settings.ini file at ~/.config/gtk-3.0/settings.ini and add the line:

gtk-menu-bar-accel=""
8
  • Thank you for the quick reply! This kind of works - with SHIFT + F10 mc closes without asking questions. F10 by itself has no "positive" effect - it will focus the "search" widget. I tried to unbind it by using the syntax you provided but could not make it to behave. Do you have other suggestions?
    – SoftExpert
    Aug 13, 2015 at 20:24
  • I think this is somehow expected behavior since in terminal applications everything with shift goes to the shell. No other suggestion. I think you have to use or dig deep into this stuff bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/937822
    – Djax
    Aug 13, 2015 at 20:27
  • Sorry, I pressed Enter before finishing my comment.
    – SoftExpert
    Aug 13, 2015 at 20:29
  • I put following config: @binding-set NoKeyboardNavigation { unbind "F10", unbind "<shift>F10" } * { gtk-key-bindings: NoKeyboardNavigation } but F10 will still focus the "search" widget.
    – SoftExpert
    Aug 13, 2015 at 20:31
  • I found the solution that works - at least for me: I added gtk-menu-bar-accel="" in the settings.ini inside ~/.config/gtk-3.0. Thank you @Djax - I followed your suggestion and sifting through the bugs related I found solution here bug #661973
    – SoftExpert
    Aug 17, 2015 at 10:42
2

My settings.ini was empty so I actually had to add Settings section to ~/.config/gtk-3.0/settings.ini [Settings] gtk-menu-bar-accel=""

2
  • Jan Klepal's answer is working. Settings section should be exist to solve this issue.
    – Insspb
    Jul 10, 2017 at 11:42
  • gtk-menu-bar-accel="" works but it creates lots of error messages. gtk-menu-bar-accel= is better ie without the quotes
    – wef
    Mar 6, 2021 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.