I am using a Dell XPS 13 9350 with a Broadcom BCM4350 wifi card. I'm unable to connect to wifi or even see the option to in the network settings area.

Troubleshooting steps taken: typed sudo apt-get purge bcmwl-kernel-source in terminal then rebooted Then reinstalled the latest bcmwl kernel then rebooted reinstalled elementary with wired connection disabled, enabled, and activated network service (Network.service) tried other distros (Fedora as an example) and I was able to connect

**output from lspci -nnk | grep -iA3 net; rfkill list all

3a:00.0 Network controller [0280]: Broadcom Corporation BCM4350 802.11ac Wireless Network Adapter [14e4:43a3] (rev 08) Subsystem: Dell BCM4350 802.11ac Wireless Network Adapter [1028:0023] Kernel modules: brcmfmac, wl 3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01) Subsystem: Dell RTS525A PCI Express Card Reader [1028:0704] 0: hci0: Bluetooth Soft blocked: no Hard blocked: no

I see that a lot of other people are having the same issue and one user had the exact same machine I do and was unable to connect to wifi or see any option to connect. Unfortunately his question was not answered.

I'd appreciate any help you guys can give me!

  • Please edit the question to include results for lspci -nnk | grep -iA3 net; rfkill list all
    – Jeremy31
    Jul 9, 2017 at 12:58
  • Edited to include the output from the command.
    – trajoh
    Jul 9, 2017 at 22:15

2 Answers 2


That chipset isn't correctly supported by bcmwl-kernel-source, so uninstall it with

sudo apt-get purge bcmwl-kernel-source

Reboot and if it still doesn't look at results for rfkill list all if nothing is blocked, in terminal do

echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf


Installing bcmwl-kernel-source will blacklist the open source kernel modules that do support your device. Sometimes the older b43 and ssb modules will conflict with bcma and brcmfmac


I had this computer and wifi card, the main problem is that the card uses dell firmware. It works randomly, depending on kernel firmwares. There are tons of messages about this on dell forums. Dell french support even contacted me to get technical details about this. I had to buy an intel wireless card to solve the problem.

  • Do you remember which card you replaced it with?
    – trajoh
    Jul 9, 2017 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.