So, I was playing around yesterday, and decided to uninstall lightdm and make an xinitrc file to start from the terminal at boot, as I like to do. Well, after doing so, I am unable to play any videos in audience, or Videos, as it is called in the icon. I did reinstall lightdm, but I fear I may have futzed up the session too much, so this happens:

[ERROR 14:08:17.236311] Inhibitor.vala:62: Could not inhibit screen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ScreenSaver was not provided by any .service files

I would like very much to not have to install another video program, so just what the hell have I done? I would very much appreciate any help anybody could provide to me for this.


1 Answer 1


I fixed it by doing the following, as it needed some packages from elementary-desktop:

sudo apt install elementary-desktop --reinstall

And now it works just fine.

  • Can you please mark this as answered? Thanks!
    – pretz
    Dec 29, 2017 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.