0

I am able to assign an additional shortcut to zoom in and out using the System Settings > Keyboard > Universal Access > Magnifier Zoom In/Out options, but regardless of what I set there, the shortcuts Meta+= and Meta+- still zoom in and out. It's conflicting with a shortcut in another program.

1

I discovered a workaround via this answer to a related question.

First, use gsettings to find the internal configuration setting we wish to change:

gsettings list-recursively | grep -i zoom
# ...
# org.pantheon.desktop.gala.keybindings zoom-out ['<Super>minus', '<Super>KP_Subtract']
# org.pantheon.desktop.gala.keybindings zoom-in ['<Super>plus', '<Super>KP_Add']
# ...

Then, change the individual setting as necessary. In my case:

gsettings set org.pantheon.desktop.gala.keybindings zoom-out "[]"
gsettings set org.pantheon.desktop.gala.keybindings zoom-in "[]"

Then you should be able to use the built in elementaryOS settings for the shortcut you want.

It seems like this may be a bug in ElementaryOS. https://github.com/elementary/switchboard-plug-keyboard/issues/31?_pjax=%23js-repo-pjax-container

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.