2

I installed elementaryos-0.4.1-stable.20170517.iso several times on my intel/nvidia laptop the first time i did the install i could enter numbers on my numpad. After doing a clean install, now on boot numlock is OFF by default no matter what state i leave it in before i shut it down. I tried adding

greeter-setup-script=/usr/bin/numlockx on

after

sudo nano /etc/lightdm/lightdm.conf

which led to not being able to boot so then using ctrl+c at boot and recovery mode removed it back to normal, i saw older posts on this forum that you could just open settings->keyboard but i believe that was relevant for a version 2 yrs ago.

I am up to date to latest version as of this post

  • It's very weird, that command must fix that, can you please output your /etc/lightdm/lightdm.conf ? – Egon Stetmann. Jun 20 '17 at 6:43
  • the document appears to be blank, maybe that is how it was done in the older versions – Big Smoke Jun 20 '17 at 15:05
  • 1
    So i figured it out sudo nano /etc/lightdm/pantheon-greeter.conf then add activate-numlock=true that fixed it – Big Smoke Jun 20 '17 at 15:10
  • I forgot that elementary uses his own greeter, glad to see that you fixed your problem – Egon Stetmann. Jun 20 '17 at 18:22
  • see my comment in another question. elementaryos.stackexchange.com/a/12745/8404 – Deyvison Rocha Jul 18 '17 at 22:12
0

Adding/editing greeter-setup-script=/usr/bin/numlockx on in /etc/lightdm/lightdm.conf works for me on elementary OS 5.1.6 Hera very well. https://wiki.archlinux.org/index.php/LightDM#NumLock_on_by_default confirms this solution. Just for the case someone else is looking for a way to enable NumLock in login screen on default.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.