First, bluetooth device search didn't find my speaker, so I followed this post. Using bluetoothctl I could pair, connect, and trust my speaker and clicking on the bluetooth icon shows my speaker, however it still doesn't show up in device search.

After connecting via bluetoothctl it worked at first, but when I connect now either via the bluetooth icon or the command line it says it is connected, but it isn't really, since the speaker doesn't appear in sound settings and the audio continues to be played over my laptop speakers. It disconnects and connects regularly. The output is the following:

sudo bluetoothctl -a
[NEW] Controller 34:DE:1A:4D:1F:8D loki [default]
[NEW] Device 00:E0:4C:43:F2:51 SoundCore mini
Agent registered
[bluetooth]# connect 00:E0:4C:43:F2:51
Attempting to connect to 00:E0:4C:43:F2:51
[CHG] Device 00:E0:4C:43:F2:51 Connected: yes
Connection successful
[CHG] Device 00:E0:4C:43:F2:51 Connected: no
[CHG] Device 00:E0:4C:43:F2:51 Connected: yes
[CHG] Device 00:E0:4C:43:F2:51 Connected: no
[CHG] Device 00:E0:4C:43:F2:51 Connected: yes
[CHG] Device 00:E0:4C:43:F2:51 Connected: no

and so on.. I followed the instructions in this post as well, but pulseaudio-module-bluetooth is installed and killing and restarting pulseaudio didn't solve the problem. module-bluetooth-discover is loaded:

pactl list short | grep blue
8   module-bluetooth-policy     
9   module-bluetooth-discover       
10  module-bluez5-discover

Trying to load the module results in the following error, but I guess that's irrelevant, since it's loaded already:

sudo pactl load-module module-bluetooth-discover
Home directory not accessible: Permission denied
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Does anyone have an idea why it first worked and then not anymore? Could it have anything to do with the fact that after it first worked I connected my phone to the speaker? It isn't connected anymore, of course. Thanks for any help.

By the way, I just tried to connect another bluetooth speaker and it worked, with the speaker showing up in device search as well. I don't think that there is any problem with the other speaker though, I've never had problems connecting to it with different phones or windows computers.

  • anyone? the problem persists, I cannot connect to that speaker anymore, it says connected, but doesn't appear in sound settings and disconnects all the time
    – iuvbio
    Commented Jun 20, 2017 at 16:58
  • Does this OS ever work for bluetooth Audio?
    – Chuxxsss
    Commented Jun 26, 2017 at 8:07
  • Yes, I could connect another Bluetooth speaker, as well as my phone
    – iuvbio
    Commented Jul 6, 2017 at 20:30
  • I have a very similar issue with trying to pair with an Anker SoundCoreMini on Loki. I went through the same steps as you, and I also could not load the module-bluetooth-discover, although I got a Module initialization failed message. Did u ever resolve this issue?
    – user10425
    Commented Oct 7, 2017 at 17:28
  • Hi @JamesAdamCampbell, in fact I was using the exact same speaker. Unfortunately no, I never got it resolved. Let me know if you have any success.
    – iuvbio
    Commented Oct 26, 2017 at 17:33


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.