I successfully installed Loki on my new laptop that initially came Windows 10 preinstalled, and was capable of connecting to wireless internet. Because I already own a Windows machine, I decided to clean install Elementary OS. The USB installation went well, except that I can't seem to find a way to connect to internet wirelessly; for the records, there's no wifi icon in the toolbar, and no options to explore wireless network options. I browsed the online forums and other documentation, but with no luck. Could it the be the question of drives? But again, wouldn't those be installed with Loki?

The laptop used to install Elementary OS is a rather modest device that I intend to use as a learning Linux machine: Intel Atom Quad Core Processor, 2GB RAM, 32GB Flash Storage.

Thank you very much for your time to read my question and your help.


2 Answers 2


I'm assuming for what you said, you are learning Linux, so I'm going to explain briefly every command. But consider Reading the man [command] pages of every command before using it.

I'm assuming that your daemon is not working, but just for make sure, check out you BIOS network configuration, maybe the Wireless antenna is turned off.

You installed a new eOS so I'm sure you didn't touch the root user, so first we need to configurate that, now open a terminal type SUPER + T and write this command:

$ sudo passwd root

Then enter the password you want, note that root is the god user that can do literally everything in you Linux machine... we need to log in the root user for managing the daemons without problems, I don't recommend using sudo with your user even if is admin because it really doesn't have all the privileges of a root user at all. So for loggin into the root user just type:

$ su root

and enter the password you already typed.
Now we need to reconfigurate the networkmanager.service so for that...

# systemctl disable NetworkManager.service
# systemctl enable NetworkManager.service
# systemctl restart NetworkManager.service

So with that done we basically restarted the service, now type exit and reboot your computer. Note the # that means that you are using the root user and not the standard user reprecented by $ this thing is used in most of Linux webpages so keep an eye for that.

Now finally if for some reason, you aren't watching the tray wifi icon, enter the terminal again and type:

$ nmcli dev wifi connect "NAME_OF_YOUR_WIFI" password "type_password"

And yes write even the " this method is used because in bash (Linux console) when you enter SPACE means you are using a command or parameter(this is called pipeline, not sure). When using the " you are telling the console that you will enter a string and evaluate if it is exactly the same coincidence (string = word/sentence).

Now you're done, if for some weird reason you are still unable to use the wireless, let me know, please don't use the root user for common things like installing programs, the root user is only for manipulating other users and special kernel configurations such as daemons and hooks.

You can learn more about Networkmanager commands here.

Another method is using the iw network program, so for installing it...

sudo apt install iw

but is probably you have that already installed, so first we need to know the name of your Wireless card, for that type

iw dev

the output will show you something like wlan0 use the same name of that for the next command... now finally for connecting to the internet type and hit ENTER

iw dev wlan0 connect "name_of_wifi"

the screen will turn blue and will ask you for the password, that's all I know for fixing that kind of problems, hope this will work.


I think Windows is spoiling your BIOS, I can't explain why but my friends done this...
Enter a terminal, and type sudo nano /etc/default/grub
and add this piece of code acpi_osi=Linux, where it says : GRUB_CMDLINE_LINUX_DEFAULT
so it will turn into GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
that parameter tells grub to take full control of the computer hardware when there are others OS in the hard disk.
Exit and save changes to the file with CTRL + X
and update the grub with sudo update-grub

GRUB is a boot loader package that supports multiple operating systems on a computer, it handles hard stuff with the kernel, we don't want to know ;)

  • if no one of this commands fix your problem then reinstall elementary Jun 16, 2017 at 22:21
  • Thanks, Renato. I appreciate you taking time to reply to my inquiry. Soon after I posted my question (and before I read your reply), I tried installing Linux again, this time with the Ethernet cable connected (not wireless) and it all worked just great! Do you think that next time I should connect to wifi in "Try Linux" mode before installing it on the machine without Ethernet connection?
    – user10173
    Jun 23, 2017 at 21:25
  • another thing I don't know is that some wificards are incompatible with the Linux kernel, because of propietary software... you must use a generic driver instead .. but I don't know how Oct 2, 2018 at 13:38
  • still cant get wifi working after this: david@david-Lenovo-ideapad-330-15AST:~$ iwconfig enp2s0 no wireless extensions. lo no wireless extensions. david@david-Lenovo-ideapad-330-15AST:~$ May 2, 2019 at 5:56

Renato, Thank you once again for your suggestions. I just successfully installed Elementary OS on my new Lenovo Yoga along with Windows 10. This time I didn’t have a way to use Ethernet to connect to Internet, so I hoped the wireless would work…

At the beginning of the installation, I was asked if I wish to connect to the wireless network, in particular to my wireless card Qualcomm Atheros QCA61x4A. After selecting this option, I was asked for password, which I imagined was my wifi password (?). It didn’t seem like I actually connected to wifi, but still decided to proceed with the installation.

Realizing that, similar to my initial attempt to install Linux, after installing Elementary on a different machine I also wasn’t able to connect to wifi, I did what you suggested in your reply, but with no avail. I will certainly attempt to do it again, but in case you have any other suggestions, please let me know. The wifi is working just fine on the Windows end …

Here’s some more information on what I got in terminal. When I typed $ sudo nmcli dev wifi connect "NAME_OF_YOUR_WIFI" password "type_password”, I got the error: No network with SSID ‘NAME_OF_YOUR_WIFI’ found. Meanwhile, the iw program is installed. It’s interesting that when I typed iw dev, I didn’t get anything that resembled to Qualcomm Atheros, and it wasn’t wlan0, either. I got this instead:

phy#0 Interface wlp1s0 ifindex 2 wdev 0x1 add cc:b0:da:b5:1a:5d type managed

THANK YOU so much for your time! I hope to get to the bottom of this one way or another. Best regards!

  • duude that means that something weird is blocking your wifi... maybe windows is spoiling the card, I'll update the answer Oct 1, 2018 at 16:29
  • and I think your wifi card is called wlp1s0 Oct 1, 2018 at 16:44
  • please consider updating your question instead of posting a solution here(also delete this post because is not an answer)... the stackexchange site is very hard with the users, when following the Q&A proccedure... Oct 1, 2018 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.