6

I installed Telegram messenger from ppa:atareao/telegram (Source: Web Upd8).

Telegram messenger is a Qt app. elementary OS seem to set the Qt style to Windows instead of default. This results in the Telegram messenger dialog window not using the QtCreator but the Windows dialog.

This is the windows dialog:

Windows dialog

This is the Qt Dialog that I want to use:

Qt Dialog

The issue is described in more detail there:

  • Make tdesktop look native / Do not set Qt style to win by default #987
  • Can the Linux client use GTK FileChooser? #982

My question to the community is the following:

How do I configure my elementary OS setup to make Telegram use the Qt Dialog?

5

What I did for change the Qt apps style is add this line:

QT_STYLE_OVERRIDE=gtk

In the environment file:

gedit /etc/environment

Then reboot the system.

This is how Focus Writer looks like in my system: enter image description here

| improve this answer | |
  • I tried your solution, but it does not work with FocusWriter. Could you test FocusWriter yourself and please confirm that your answer integrates FocusWriter properly? Thanks! – orschiro Aug 29 '15 at 11:59
  • I've attached a pic of how FocusWriter looks like in my system, is this the style you want? – ikaro Aug 31 '15 at 6:36
  • 1
    Yes, that's how I want it to be! I notice that you have a spelling mistake in your answer regarding /etc/environtment. – orschiro Sep 3 '15 at 9:34
1

You should go through this bug report.

qtgtk style cannot detect elementary gtk style

There are fixes mentioned in this report.

The first being(for x86_64):

gconftool-2 --set --type string /desktop/gnome/interface/gtk_theme Elementary

And for 32bit applications on x86_64:

Install ia32-libs

According to this post ia32-libs is no longer included in the os.

Since Ubuntu 11.10 Multiarch has been added.

Anyway, to explicitly install ia32-libs:

sudo -i
cd /etc/apt/sources.list.d
echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list
apt-get update
apt-get install ia32-libs

According to this you can also try installing 32bit library of the application:

apt-get install program:i386
| improve this answer | |
  • Thanks! Can you give some examples of application-specific ia32-libs packages? – orschiro Aug 27 '15 at 13:03
  • ia32-libs helps getting 32bit packages installed on 64bit machine. This hack has become quite old now and is not being used since Ubuntu 11.10. Multiarch is being used now. I have updated my answer accordingly. – sissyphus_69 Aug 28 '15 at 6:17
  • Can you give any explanation for adding this specific repository? raring is not the Ubuntu version Freya is based on. Moreover, raring is discontinued (as it's on old-releases.ubuntu.com). Your answer sounds dangerous to users and I don't see any sense in adding the raring repository. As said in your link about ia32-libs, it's an obsolete concept and shouldn't be used anymore. Please don't tell people how to do things wrong. – embik Aug 28 '15 at 16:01
  • I like writing detailed answers, providing every possible way to solve a problem. I'm sorry if you find this answer dangerous. I know elementary freya is not based on ubuntu 11 and if you read my answer as well as the comments, you will see that i have mentioned that the process of using ia32-libs is old now and that it has been replaced with Multiarch. I also provided links that explains things in details so that before using what i wrote, people can choose which method they want to solve a particular problem. But what you said, i will surely keep this in mind. – sissyphus_69 Aug 28 '15 at 16:35
  • @godslayer_69 I tried your proposed solution for x86_64 but it does not change the design with respect to FocusWriter. Could you test FocusWriter yourself and report back whether your solution works for you? Thanks! – orschiro Aug 29 '15 at 12:00
0

Just FYI after this bug/request was filed for Loki beta2 (or nearly-RC1): https://bugs.launchpad.net/elementaryos/+bug/1616838 it appears to have been addressed here: http://bazaar.launchpad.net/~elementary-os/elementaryos/default-settings-loki/revision/207

While this does seem to help with the look and feel, not sure how/if it helps with the file dialog issue, maybe that's more work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.