I can't read my digital newspaper on my pc because it needs Adobe Flash to open it. I am using Elementary Loki with Google Chrome. I have tried several things from several forums which didn't work and they were all for Ubuntu and other distros or for Firefox, also I am a beginner but I have learned several useful commands.

I have tried the following unsuccessfully:

  • Tried finding Canonical Partners in AppCenter, but couldn't find any.
  • Tried to find support for Chrome, only found for Firefox and nothing worked.
  • Tried sudo apt-get install adobe-flashplugin
  • Tried downloading flash.tar.gz and

    cd /tmp
    tar -xvf flash.tar.gz
    if ! [ -d /usr/lib/adobe-flashplugin/ ]; then
      sudo mkdir /usr/lib/adobe-flashplugin ;
      echo /usr/lib/adobe-flashplugin/ already exists ;
    sudo cp -f libflashplayer.so /usr/lib/adobe-flashplugin/
    sudo ln -sf /usr/lib/adobe-flashplugin/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so 

    and got an error:

    cp: cannot stat 'libflashplayer.so': No such file or directory

elementary OS 0.4.1 Loki (64-bit)
Processor: Quad-Core Intel® Core™ i5-4200U CPU @ 1.60GHz
Memory: 3,9 GB
Graphics: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

3 Answers 3


I know this is an older post but I ran across this post while looking into my own issue and figured I would provide the solution I found.

In Chromium: After installing the "pepperflashplugin-nonfree" I was able to enable it in Chromium and access content as usual. I suspect bugs (or what have you) have been corrected since this post.

Below commands in terminal:

sudo apt-get install ubuntu-restricted-extras

sudo apt-get install pepperflashplugin-nonfree

With Firefox: I was able to get the "libflashplayer.so" file from here @ Adobe Flash Player. After downloading the tar.gz file, I copied and pasted the file in "/usr/lib/mozilla/plugins".

Then, I restarted the browser in firefox and was golden from there.

This info came from here @ Mozilla Support.

Hope this helps someone down the road.


Install It using :
~$ sudo apt-get install flashplugin-installer


Getting flash to work reliably on new versions of Chrome can be a bit of a pain in Linux. I've had mixed results. But this might get you started:

  1. Make sure you have pepperflash (Chromes flash alternative) installed on your system

    sudo apt install synaptic
  2. Within Synaptic search on pepperflash and check the box then install it

  3. Go here for the Google Chrome support with instructions on how to enable flash within Chrome

  • 1
    I've installed Synaptic and also pepperflash, even followed all chrome configurations from your link, still when I click on the newspaper link it takes me to adobe page. I really need this to work to prove a point to some friends. They think that GNU/LINUX is still too limited. But I know better, I run pretty much everythin in it, the only glitch has been this Flash Player. I would welcome more ideas, but if you have no further instructions, I would like to say that I really appreciate you support, it meant a lot!!!
    – Marcelo
    Commented Jun 13, 2017 at 20:48
  • Like I said, flash is really buggy in Chrome. You might want to run Firefox for that. Also have you tried the default browser, Epiphany?
    – pretz
    Commented Jun 14, 2017 at 11:45
  • 1
    I use Firefox to read my digital newspaper but the reason why I was using Chrome is that I also have Netflix and it won't run on Firefox. So, I thought that I could get only one browser to do both things, perhaps Firefox, and this would also show my friends that it wasn't that hard to make the transition to GNU/Linux. Nevertheless, this is not a dealbreaker for me. I am happy and grateful with the GNU/Linux. And once again, your help has proven vital and I can't thank you enough!
    – Marcelo
    Commented Jun 15, 2017 at 10:10
  • 1
    I think this might resolve your issue: askubuntu.com/questions/912544/…
    – pretz
    Commented Jun 15, 2017 at 18:28
  • 1
    Fantastic!!! It worked just fine, thank you so much!!!
    – Marcelo
    Commented Jun 15, 2017 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.