0

Alrighty, I have a serious super important mega critical issue; dear god someone help me. My video games don't work! Okay some do, if I install a game using Steam, they always work and run without a hitch.

However, if I download and install a game, any game, through GOG, they do not work. The icon pops up but nothing happens and the game crashes. I am not sure what to do here as games do work through Steam.

Here are the games I have tested:

  • Victor Vran
  • Shadowrun Returns
  • Hotline Miami 2
  • Doorkickers

My assumption is that it has to do with Elementary being 64-bit

2

This is a late answer, but I'll try to help in case you're still having this problem or if someone else stumbles upon this page. :) Note that this might not be a recommended or most optimal way of solving these kinds of issues, but it's how I do it.

My assumption is that it has to do with Elementary being 64-bit

This can indeed be the case. You can enable the installation of 32-bit versions of packages by running this command in the terminal:

sudo dpkg --add-architecture i386

This needs to be enabled for the following to work.

So, next I'll show you GOG's version of Crimsonland as an example. It did not launch right away, so I ran it through the terminal. You can launch a terminal in the game's folder by navigating to it in Files (Home -> GOG Games -> Gamename), right-clicking the file area and choosing "Open with an application -> Terminal". Then run the command ./start.sh as in the following image. Most, if not all, Linux GOG games are run via the file start.shTrying to launch GOG's version of Crimsonland via the terminal.

Notice that the error message shows the name of a library: libopenal.so.1

Now you need to figure out what package this might relate to. I searched for libopenal by using the Synaptic Package Manager application available on the elementary AppCentre. I found a package called libopenal1 of which the 64-bit version was already installed. I decided to try installing the 32-bit version of it as well.

I closed the Synaptic Package Manager and issued the following command on the terminal:

sudo apt install libopenal1:i386

Notice the important part: I put :i386 at the end of the package name. This means that I am asking apt to install the 32-bit version of the package.

I proceeded with the installation and afterwards tried starting the game again. It worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.