0

I'm Using elementary OS 0.4.1 Loki , in which the Bleachbit 1.12 with root privilege option is not working at all. App's icon just pops on the Plank Dock and Closes itself after some time. Nothing happens.

I tried using terminal by typing sudo bleachbit but this is what get

ABCD@xxxx:~$ sudo bleachbit
[sudo] password for xxxxxxxx: *********************             

(bleachbit:5756): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(bleachbit:5756): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(bleachbit:5756): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(bleachbit:5756): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

After this bleachbit without root option window opens and that is running smoothly. This auto update option says that im in root privilege as in the picture. But options in Bleachbit are as same as normal not as root. enter image description here

P.S I've also tried Bleachbit Beta 1.17 -------> SAME RESULT

2

For some reason, Loki doesn't come pre-installed with gksudo. When you launch BleachBit as root, it expects gksudo to be installed, so that it can prompt you for elevation.

In order to get this to work right, all you need to do is to install gksudo.

$ sudo apt install gksu

After executing this step, launching BleachBit as root should work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.