In Elementary OS Loki, if I run the command xmodmap -e "keysym Super_L = Multi_key" it works nicely, and I can use the left Windows key as Composer. But the effect do not last. If a lock the screen and when around for a while (cannot say how long, but say half an hour), when I come back I have to run xmodmap again.



1 Answer 1


I noticed that running xmodmap works until the system is restarted. In my case it helped to add it to System Settings > Applications > Startup. The paths in the command should be absolute, otherwise they will not be recognized correctly:

/usr/bin/xmodmap /home/{your_user_name}/.Xmodmap

I realize that your problem is different, but this solution might help. You might also consider adding this command to .profile in your home directory (although it didn't work in my case).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.