0

Update progress reached this point after 30 minutes then stuck for the past ~8 hours

I was trying to update the operating system through AppCenter. It has been running for over 8 hours (still running). Would like to know:

  1. Is this normal?
  2. Is it safe to stop the update?
  3. Any way to stop this safely...

For now I have made a backup of my files. I have experienced something similar in the past and tried to solve it by force shut down the system. A bad move that resulted in a complete OS reinstall..

Please let me know if any more information is needed. Any help or advice is greatly appreciated!

1

If this is a fresh install, I always log in and restart before running any updates because I've had this issue as well. Logging out of your session might fix it.

  • Unfortunately, this install has been my daily driver for a few months now. Would hate to re-setup everything again. – Chi Kit Yeung Jun 6 '17 at 3:32
  • 1
    Tried logging out and it worked! – Chi Kit Yeung Jun 6 '17 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.