0

I'm trying to use IntelliJ Idea for some Kotlin development, and coming from Mac, I wanted to use the Mac key bindings. They rely fairly heavily on the Super key as an alternative to the Command key on Mac, and I find that IntelliJ is entirely unable to pick up Super+anything keybindings.

That is to say, if I wanted to, say, undo something, the "Macish" keybinding is set to Super+z, and if I actually press that combination, it just prints a z to the screen. Similarly, if I want to quit a tab, I try Super+w and it just prints a w to the screen.

I tried disabling virtually all the keyboard keybindings in the Elementary OS Keyboard Settings menu that use the Super key. It still seems that the modifier is not reaching the app.

Any ideas on how I might be able to fix this behavior? Thanks!

0

This is lame but most of linux distros comes with prebuilt keybindings for people who quits windows, so... that explains your problem.

Have you tried using CNTRL key instead of SUPER ? if that doesn't work you should read this. And change the keymaps for your use.

Another solution is to change the keymap of the system for Mac support, maybe the kernel doesnt configure that well, have you checked that? Let me know

UPDATE

So i investigate more and found this method if not try this other one.

  • Thanks for the response, Renato. I can change the shortcuts, and use Ctrl if I need to, but I'm coming from Mac, so I would really like to use (for example) Meta + R = Run tests, or Meta + Shift + R = run tests under cursor. The "default" linux key bindings are Shift + F10 and Ctrl + Shift + F10 for those respectively and I'm not the biggest fan, they require me to reach much further on the keyboard. – Nikhil Gajwani Jun 7 '17 at 0:32
  • @NikhilGajwani please check out the new links – Egon Stetmann. Jun 7 '17 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.