9

I have my laptop set up to go to sleep after 30 minutes:

sleep settings

When I come back to my computer, and unlock it by entering the password for my user account, a notification pops up in the upper right corner of my screen as soon as the computer is unlocked, which reads:

Automatic suspend

Computer will suspend very soon because of inactivity.

enter image description here

It would make sense if this notification popped up before going to sleep, but I do not understand why it pops up after I "wake up" my computer. It's slightly annoying because I then have to manually close the notification by clicking the 'X'-- it does not go away on its own.

How do I change this behavior so that the notification does not pop up when I wake the laptop? And/or, how do I make this specific notification disappear on its own?

1

You simply can't, because of the way the system is designed.

The notification is not meant to be transient, because it's related to power management and therefore pretty critical for you to take action on.

However, if you lock the screen, the system cannot show anything from your user on the screen (above the lock screen), so this notification will wait until you've unlocked the system in order to pop up.

I think what you would need to do instead is to report a wishlist bug against the power manager with regards to the behaviour you would like to see.

1

I think that this notification is started by the power management program, so if you want to delete it you can easily disable power management notification in SettingsNotificationsPower → Disable bubbles and sound.

Anyway with this method you will also lose notification bubble for low battery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.