0

I'm a new user in Elementary OS (0.4.1 Loki) and I find it really amazing. But I have a problem that I cannot resolve. I installed xampp for linux and all works fine but I wanted to put it in the plank with the others applications. Anyway, I find some tutorial and all say that I have to create the directory:

/usr/share/applications/lampp.desktop

and put inside it lampp.desktop

Now I have the icon but when I click on it nothing appear. Seems like it's loading for a bit but nothing happen after that shot time.

I also try to replace:

Exec=gksu ./opt ...

Exec=gksudo ./opt ...

Exec=./ ... (in this case no icon appear)

How can I solve it?

I'm sorry if I say something wrong but I'm also new in Linux and still learning the basics.

0

I believe you also need to specify a Path in the .desktop file. Use this image as an example.

enter image description here

If you need to run it as root, add gksu before the command:

Exec=gksu /opt/lampp/manager-linux-x64.sh
Path=/opt/lampp

  • I still don't understand why in the tutorial there wasn't the Path line. Thank you so much, now it works! Anyway, if I could ask, what is the difference between sudo and gksu in this case? Why with the first one it didn't open? – Peto May 31 '17 at 6:19
  • Glad it worked. Simply put, gksu displays the password prompt window, while sudo works only from Terminal. – Vlad Pop May 31 '17 at 7:43
0

you can try to add the menu using menulibre

sudo apt update && sudo apt install menulibre

add costum menu there, and drag the menu from slingshot to plank

0

I would check your exec path. You have ./opt, you should not have a . in front of your root. Could be why nothing is executing, linux can't find it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.