0

I am running on a freshly updated elementary OS 0.4.1 Loki.

When trying to install the elementary-sdk, I get the following error message.

$ sudo apt install elementary-sdk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 elementary-sdk : Depends: libgala-dev but it is not going to be installed
                  Depends: libgranite-dev but it is not going to be installed
                  Depends: libgtk-3-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Am I missing something here? Is there anything I can do to debug this issue and fix it?

EDIT: Added current active sources & sources.d

Current sources.list

$ cat /etc/apt/sources.list | grep ^deb
deb http://in.archive.ubuntu.com/ubuntu/ xenial main restricted
deb http://in.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb http://in.archive.ubuntu.com/ubuntu/ xenial universe
deb http://in.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb http://in.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://in.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb http://in.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse

Current sources.d

$ tail -n +1 /etc/apt/sources.list.d/*.list
==> /etc/apt/sources.list.d/elementary.list <==
deb http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial main
deb-src http://ppa.launchpad.net/elementary-os/stable/ubuntu xenial main

==> /etc/apt/sources.list.d/patches.list <==
deb http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial main
deb-src http://ppa.launchpad.net/elementary-os/os-patches/ubuntu xenial main
  • 1
    have you tried to install them independently? – Mike Rodov May 27 '17 at 7:10
  • @MikeRodov Trying to install them independently gives me another list of dependencies... Not sure I want to go down this rabbit hole :) $ sudo apt install libgala-dev ..... The following packages have unmet dependencies: libgala-dev : Depends: libmutter-0-dev (>= 3.23.90) but it is not installable or libmutter-dev (>= 3.14.4) but it is not going to be installed – Aditya Ravi Shankar May 27 '17 at 7:45
  • I'm getting the same MSG. I'm trying to install elementary-sdk but I keep getting errors: libgala-dev : Depends: libmutter-0-dev (>= 3.23.90) but it is not installable or libmutter-dev (>= 3.14.4) but it is not installable – Reya276 Mar 13 '18 at 17:04
0

Are you using additional PPAs? If yes, try disabling all of them and see if the installation will proceed.

  • I've added my current sources.list and sources.d content. Not sure I see anything that can be a problem. – Aditya Ravi Shankar May 29 '17 at 10:23
0

Never mind... Just did it the hard way...

Backed up home and reinstalled eOS... Oddly enough, this took less time than everything else I tried...

0

Although OP solved via re-install, I also had the same issue and was able to solve it another way.

Seems I had installed libpng16-dev which caused these same dependency issues. After removing it and installing libpng12-dev instead, I was able to install elementary-sdk succesfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.