When I restart my OS, I log in. The desktop does not load for a full 2 minutes after typing my password. I can move my mouse and see my desktop background. No apps. Happens pretty much every time I reboot. I have a 2017 Dell XPS. Performance is excellent other than this odd issue.

How do I figure out what is causing this? How can I fix it?

  • 1
    I'm facing the same problems. The login bug was already addressed to the development team: bugs.launchpad.net/elementaryos/+bug/1596377 – user6390 Sep 16 '16 at 16:50
  • Ash, thank you, I hadn't seen this. I'm glad that the bug has been brought to their attention. Apart from a few other minor things, I am loving this new env though! – Rarcas Sep 16 '16 at 17:23
  • I have the same issue as you, after loading to my login screen it takes a lot of time to load the dock and the panel, quite confusing, still unable to locate the issue.Anyone? – user6421 Sep 17 '16 at 23:14
  • who can help me – user8167 Jan 18 '17 at 12:24
  • Can confirm that running sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled fixed the issue on both of my devices. Thanks I read and find this way to fix it ,but I'm not sure, I haven't try it.when I tried I will report it – user8167 Jan 20 '17 at 15:53

A solution (or at least temporary workaround) proposed in the bug discussion - https://bugs.launchpad.net/elementaryos/+bug/1596377 - is to rename the file:




This fixed it immediately for me.

  • thanks, that worked for me too bro!!! right now after login just take 2-10 seconds :)) – arif ardiansyah Mar 13 '17 at 2:13
  • This also resolved the problem for me. Thanks a lot. – JoeFox Apr 18 '17 at 18:31
  • 1
    Didn't worked for me – jpmottin Mar 26 '18 at 18:17

This is a known bug in dbus. There is an upstream fix but unfortunately it hasn't made its way into elementary yet (apparently the fix is in staging, so it should appear soon).

I think the related problem is explained and fixed here: https://mail.gnome.org/archives/commits-list/2016-July/msg02793.html

OS Loki is running dbus-daemon 1.10.6 from 2015-12-1 while the problem was fixed in July 2016. An update to newer dbus version (one after 1.10.10) should fix the issue.

To fix the issue for now: Rename the file to at-spi-dbus-bus.desktop


If you don't want to mess about with files I've found the following temporary workaround:

  1. Enter a PTTY (Press CTRL + ALT + F1.

  2. Login.

  3. Restart lightdm with sudo systemctl restart lightdm.

  4. You will be taken back to the login screen, login and Slingshot should appear instantly this time.

  • Thanks a lot I read it and find. Something I will try it – user8167 Jan 20 '17 at 15:54
  • Don't forget to mark the question as answered once you find your solution! – Mike Wild Jan 20 '17 at 16:09
  • I'm not sure whether it can be Fixed I haven't tried it. When I Fixed it . I will be change it – user8167 Jan 20 '17 at 16:22
  • When I do this command, my screen goes black and I only see my mouse in the middle of my screen. – jpmottin Mar 26 '18 at 18:22

Same issue here, to temporarily avoid that wait of 5 minutes:

  1. press alt+f1
  2. enter your username/password
  3. restart lightdm with sudo service lightdm restart
  • While this reduces the wait time until you can try again in the login screen, it haven't solved the recurring issue (at least for me) – Dionysius May 19 '17 at 14:50

A solution (or at least temporary workaround) proposed in the bug discussion - is to rename the file:




Yes. this happened to me as well.

  • I wait more than 30 min. But no result – Sl19 May 20 '17 at 3:11
  • can you try the above? – Mike Rodov May 20 '17 at 17:51

This is a known bug. Apparently this issue also applies to Ubuntu. There is an assistive app in the autostart that runs terribly slow. I went to the startup directory:

cd /etc/xdg/autostart/

I changed the file extension for the problem file to effectively prevent it from starting

sudo mv at-spi-dbus-bus.desktop at-spi-dbus-bus.desktop_DISABLED

Now my machine boots in ~5 seconds vs 120 seconds.

AT SPI D-Bus Bus

AT SPI stands for Assistive Technology Service Provider Interface, a framework to integrate accessibility functions in applications. This command will create a new DBus for AT SPI specific functions.
Command: /usr/lib/at-spi2-core/at-spi-bus-launcher –-launch-immediately
Status: unwanted until you need the accessibility features.
Reference: https://www.linuxfoundation.org/

This is a known bug in dbus.


sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.backup

More info: https://bugs.launchpad.net/elementaryos/+bug/1596377 or https://mail.gnome.org/archives/commits-list/2016-July/msg02793.html


I'm on a Razer Blade Stealth from late 2016 with integrated Intel graphics. I'm having this problem on a fresh install (dual-boot with Windows) and no solution seems to be helping. I renamed that file which seems to fix the problem for everyone else, I restarted lightdm, I installed drivers and updates, and I reinstalled the operating system more times than I can count. Is there anything else I can do to fix this? The default desktop background is a beautiful tree, but I'd love it if I could use eOS as an operating system instead of just a nice digital picture frame. Thank you!

protected by Community Dec 5 '18 at 23:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.