3

While attempting to create the document Hello World app from the developer docs, I found elementary-sdk to be un-installable.

user@machine-os:~$ sudo apt install elementary-sdk 
[sudo] password for user:          
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 elementary-sdk : Depends: libgala-dev but it is not going to be installed
                  Depends: libgirepository1.0-dev but it is not going to be installed
                  Depends: libgranite-dev but it is not going to be installed
                  Depends: libgtk-3-dev but it is not going to be installed
                  Depends: libwingpanel-2.0-dev but it is not going to be installed
                  Depends: valac but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I am running a fresh install of the latest version of elementaryOS: about

What should I do?

1
  • I'm facing the same problem. I opened an issue here since these instructions are currently live on the website. – waldyrious Nov 3 '17 at 13:48
1

You might want to try to install the dependency packages one by one, trying to locate what causes the error. Like what does sudo apt install libgala-dev say and so on with all packages. This way you should be able to locate the glitch.

3
  • 1
    when i do it 1 by 1, i just run into the same error with the single packages – longbow May 24 '17 at 20:25
  • You did sudo apt-get update and sudo apt-get upgrade before installing? – Jorge R. Marín May 25 '17 at 9:51
  • I'm having the same issues. Installing one by one doesn't work, as @longbow mentions, even after sudo apt-get update and sudo apt-get upgrade. I also tried sudo apt clean, sudo apt install -f and sudo dpkg --configure -a, as described here, but still no dice. – waldyrious Nov 3 '17 at 13:26
0

I install elementary-sdk on Linux-lite 5

  1. sudo add-apt-repository ppa:elementary-os/daily
  2. sudo apt update
  3. sudo apt install libgala-dev
  4. sudo apt install elementary-sdk

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.