3

For some reason, icons are showing up on the desktop. I would like nothing to show. Thanks a lot for help in advance.

enter image description here

  • Your title didn't make sense — “desktop showing in desktop” sounds like the right behavior. I edited your title based on my guess of what you meant, please make sure that my guess was correct and fix your title if it wasn't. – Gilles Aug 9 '15 at 15:40
4

This is likely caused by installing Nemo, an alternative GTK file manager. You have two options, both will likely make any icons on your desktop disappear. If you want to use icons on your desktop, check How can I place files on my desktop?.

Fix the .desktop file

To get rid of the unclosable desktop window you need to add --no-desktop to the nemo.desktop file so it reads:

Exec=nemo --no-desktop %U

By default you can find this file in /usr/share/applications/. If you made the changes there, there is a chance they get overwritten with the next update for Nemo, so it's better to first copy the file to ~/.local/share/applications/ (which is the equivalent inside your home directory):

cp /usr/share/applications/nemo.desktop ~/.local/share/applications/

and then edit it with a text editor of your choice (scratch-text-editor to start a GUI app or nano if you prefer the command line).

Based on an answer to Is Nautilus really “not-recommended”?.

Uninstall Nemo

Alternatively you can of course just remove Nemo from your system.

Simply type sudo apt-get remove nemo in terminal.

  • Btw I have seen "I would like nothing to show." but have added the link to enable a desktop regardless, as other users might want to use it. – quassy Aug 9 '15 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.