0

Just installed Elementary OS on an HP Stream notebook and the wifi will not connect. It detects the network, asks for a password sometimes, but never connects. Had the same problem in Lubuntu. I think it's the wifi chipset: RealTek 8723BE. Any advice?

  • All the above settings works for me, but have to do all those steps again after every reboot. And no conf file is generated. – Sagar Hingal Jul 22 '17 at 21:28
1

You are right the problem probably is your wifi chipset. Try this and see if it work.

Open the file /etc/modprobe.d/rtl8723be.conf with root permission and add this: options rtl8723be fwlps=N ips=N. Save the change and restart your computer.

| improve this answer | |
  • Call me daft, but I am unable to save changes to that file. New to EOS. – LowCut May 21 '17 at 18:49
  • Try to open with sudo or gksudo command. Use your text editor like scratch or install gedit and open the terminal and give this command: sudo gedit /etc/modprobe.d/rtl8723be.conf and modify the file. Now you can save. – Fasbyte01 May 21 '17 at 19:05
0

You don't need to install anything as this is an issue with HP using one antenna wire on a wireless chip with 2 antenna connections.

First we will unload the module and reload it using the module parameter to try one option for the antenna

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=1

Then we can check to see if any AP's are found with

iwlist scan | egrep -i 'ssid|quality'

Then we can try the other antenna option and compare results

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2
iwlist scan | egrep -i 'ssid|quality'

If the ant_sel=1 had better results then

echo "options rtl8723be ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723beant.conf

If ant_sel=2 was the better option

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723beant.conf

| improve this answer | |
  • This...actually freaking worked! After a reboot, it's golden. THANK YOU! – LowCut May 24 '17 at 6:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.