Problem: When I try to connect my logitech bluetooth headphones, the headphones are recognized, however, the bluetooth manager than provides a pin code asks me to input it to headphones...??? There is no input on my headphones. They are recognized as headphone/audio. Latest download available from ElementaryOS as of May Thinkpad X61 Logitek H600 headphones

Only options offered by ElementaryOS are to Input Pin on headphones, or cancel.

  • Just press accept. It should work. To connect my BT headphones I just turn them on, then I click on + on the BT settings page and then just press on the headphones. That way It pairs them automatically.
    – Maccer
    May 20, 2017 at 10:02
  • As stated, the only options offered are the pin number, and a "cancel" button... There is no "accept" button. Presumably, once the pin number has been entered on the device aide, bluetooth manager would then simply connect.
    – netcom61
    May 20, 2017 at 13:54
  • It worked! My device was listed but was toggling (connected disconnected). I first removed the device by running > remove Mac address and then followed the instructions above. Thank you!
    – Deepgain81
    Feb 27, 2018 at 22:35

1 Answer 1


I would just use terminal to pair with the headset if the bluetooth manager is causing problems

scan on
If the headset is in pairing mode it should show as a [NEW] Device followed by the MAC address and it's bluetooth name Then just do

pair followed by the MAC address- use capital letters

trust followed by the MAC and then use connect followed by the MAC and finally you can quit bluetoothctl with the quit command.

As an example, I have a device that reports as [NEW] Device E8:07:BF:05:7D:BA iHome iBT60

So I would

pair E8:07:BF:05:7D:BA
trust E8:07:BF:05:7D:BA
connect E8:07:BF:05:7D:BA

The terminal will give you feedback as the whether each command is successful. If the device doesn't show in Sound Settings after this check

pactl list short | grep blue
See if module-bluetooth-discover is loaded, if not
pactl load-module module-bluetooth-discover
Then connect to the device and it should appear in Sound Settings


  • That worked. Got them working. Guess I'll make a little shell script and a bash alias to run it... Learn something new everyday.. (should I report this as a bug somewhere?).
    – netcom61
    May 20, 2017 at 16:14
  • You shouldn't need to run the bluetoothctl commands again unless you pair the headphones with something else and you could see if the blueman bluetooth manager works better than the default one
    – Jeremy31
    May 20, 2017 at 16:36
  • Geez... better than Bluez/Bluetooth-Manager... just automatically re-connects from session to session. Thanks
    – netcom61
    May 20, 2017 at 17:22
  • 1
    If you are happy with the answer, click on the check mark to accept it
    – Jeremy31
    May 20, 2017 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.