I installed Freya recently and shortly thereafter the clock disappeared.
Sometimes I can access the calendar pop-up by randomly clicking around where the clock used to be, but this doesn't always work.

Any suggestions?

4 Answers 4


I had uninstalled evolution* packages (I thought I didn't need them) and the time indicator dissapeared

I reinstalled it with:

sudo apt-get install --reinstall indicator-datetime

logged out and everything went fine

also check: https://elementaryos.stackexchange.com/a/1377/244

  • This worked, allowing me to see both the time and the date/day/year etc. Thanks!
    – Timmo
    Commented Feb 21, 2016 at 17:59

It's a bug.

But I walked around it, randomly changing settings in dconf-editor on com > canonical > indicator > datetime.

enter image description here

  • I toggled the settings a bit, and was able to display the time, but not the date. That is, if I check show-date or show-day, the clock disappears. But at least I know the time. Thank you.
    – Timmo
    Commented Aug 9, 2015 at 23:05
  • I have no datetime category in com.canonical.indicator. any idea? what shall I reinstall?
    – opensas
    Commented Feb 12, 2016 at 14:26

This happened to me after I uninstalled the US language in the Region and Language section and left only Portuguese.

After I reinstalled the US language, the clock appeared again.

  • 2
    Can you please edit your answer to read more like an answer and less like a story :) Commented Aug 18, 2015 at 16:38
  • I went to Region and Language section and marked English (and Spanish) languages. Then logged out and issue is solved Commented Aug 22, 2016 at 9:22

I have the same issue with a wingpanel clock. I tried all instructions above, but it wasn't helped.

There are processes of the indicator:


So, it should work. However it doesn't:

enter image description here

Can anyone tell me how to fix this bug?


Done! This one works:

sudo apt install --reinstall wingpanel-indicator-datetime

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.