1

I've an ASUS N56JN and brightness shortcut doesn't work. Usually with my laptop I can do it with FN+F5/F6. How can I solve this issue? Is there a way to fix it? Thanks!

1

Use the instructions on this page, but instead go to Custom and select the + button to add a new keyboard shortcut. In the custom command, put xdotool key XF86MonBrightnessDown or xdotool key XF86MonBrightnessUp. Then click where it says Disabled and key in your key combination.

3
  • I've been doing this with xbacklight. Your solution seems better because it uses the indicator. However it's working in terminal but not as a shortcut, any ideas?
    – Eric G
    Aug 13 '17 at 7:43
  • 1
    Found an answer by myself. It needs to be: xdotool key --clearmodifiers XF86MonBrightnessUp
    – Eric G
    Sep 12 '17 at 11:43
  • make sure to install the hardware level brightness adjustment tool first by issuing sudo apt install xdotool
    – daGo
    Feb 4 at 10:50
0

I recommend setting a key binding to the two commands below.

To increase the brightness by 10% use

xbacklight -inc 10

and to decrease by 10% use

xbacklight -dec 10 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.