2

I am having some issues with Plank, so I uninstalled it by doing apt remove --purge plank. After reinstalling it, I could run the dock by starting it on the command line, but it would not start with the desktop.

I tried putting it on the startup applications on Switchboard, but it would not work anyway. How can I make plank startup automatically again on login?

2

This is controlled via a dconf setting in Loki:

gsettings set org.pantheon.desktop.cerbere monitored-processes

It should contain plank (the default is ['wingpanel', 'plank']). If plank is not listed, you can just add it:

gsettings set org.pantheon.desktop.cerbere monitored-processes "['wingpanel', 'plank']"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.