my wifi adapter is Intel® Dual Band Wireless-AC 3168 and wifi is not working . i searched for my adapter driver on intel site and found this :http://www.intel.in/content/www/in/en/support/network-and-i-o/wireless-networking/000005511.html

so according to intel website i need kernel 4.6 atleast to enable my wifi

what option i tried and failed

option1. tried to manually update kernel(Linux viking-HP-Pavilion-Notebook 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux) using commands wget http://in4serv.com.br/backup/kernel-4.6.2 sudo chmod +x kernel-4.6.2 ./kernel-4.6.2

it installed the kernel but i am unable get it running ..even tried the advanced boot option .system was still running 4.4 kernel

option2 : used ukuu kernel udate utility and installed latest kernels successfully but not able to get anyone of them running .system still boots using 4.4 kernel. the advanced boot option does not shows the latest installed kernel

option3: downloaded the driver firmware files from intel website (iwlwifi-3168-ucode-22.361476.0.tgz) and tried to copy it to /lib/firmware but unable to do so..

so i am stuck with 4.4 kernel and unable to install driver so wifi is not working

any help is highly appreciated as i wasted lots of hours to get it work but of no use..


1 Answer 1


In a terminal window

sudo apt install linux-image-extra-virtual-hwe-16.04
  • run the command but of no benift ..kernel running still 4.4 and wifi still not working..but can u tell what this command did?
    – kingviking
    May 10, 2017 at 5:23
  • Was there any output? What did happen? It is a kernel update, you have to restart computer after to run the new kernel.
    – lemonslice
    May 10, 2017 at 6:05
  • I restarted ..yes it updated the kernel but systems is Still running on 4.4 kernel .. Problem is I am able to install new kernels but elementary is still running on 4.4 ..I tried to Boot in advance option also but there also it's showing only 4.4 kernel not newly installed kernel
    – user9658
    May 10, 2017 at 7:28
  • Hold down the right shift key while booting and select the kernel. If it is not available, it was not really installed, you should try again and if there are any errors copy them here so that someone might help
    – lemonslice
    May 10, 2017 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.