I have just installed the elementary OS. The web browser is working fine. But the app centre is not downloading. I am totally discouraged and fed up using this kind of linux. not able to install wine because it is 32 bit. my goodness. wine is something so important to install and why is it not pre-installed.

  • I would ensure you have downloaded Loki from directly from the elementary.io website and not a 3rd party site to ensure you have the most current stable version. I have installed Wine on my system without issue. You might want to try install PlayOnLinux. It will install Wine along with it and might give you less trouble. – Pretzel Jones May 9 '17 at 13:01

I don't know if the version you have installed is the updated one Because there was an issue with the appcenter not so long ago (issue description) so you can follow these instructions Or you should just update the OS

sudo apt update
sudo apt upgrade

Also make sure that you are able to connect to the internet.

PS you always can install everything through apt or apt-get


I ran the commands

sudo apt update
sudo apt upgrade

It took one hour to complete the process. then the system hanged. So I forced shutdown and power on. After restart, the app centre worked fine.

This OS is aesthetic in appearance. so i liked it so much. App centre hanged again while downloading. SO i restarted again then it worked. In my experience, I have never seen linux OS gets hanged. this os is behaving like windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.