9

SOLVED 3/3

solutions + screen caps below


Tried to find a solution to this problem reading around but no one else mentioned these so posting it here considering how easily it's fixed.

Problem #1

Bluetooth Device Search window doesn't display any results.
For some reason the device results are collapsed leading the user to falsely believe no devices are being detected when in fact they are. Simply stretch the window vertically to see the results.

BEFORE Before

AFTER After

Problem #2

No Bluetooth icon under System Settings
** Missing package seems to resolve this with below command:

sudo apt-get install switchboard-plug-bluetooth

FYI: Installed packages "blueman" and "tlp" trying to resolve this but ended up removing them in the end and all works without them.

Problem #3

Poor bluetooth audio quality with headphones/speakers**
Easily solved by updating audio settings. By default the audio settings are set to Mono. Under "Sound Settings / Mode" drop down menu select "High Fidelity.."

Audio Quality Settings
Unable to post 3rd screen cap so...
i.stack.imgur.com/FdshM.png

closed as too broad by lemonslice, Daniel Foré May 12 '17 at 20:16

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    This is extremely helpful. @vmi should get answer credit for this. He spent time detailing all the issues involved and how to fix them. The question is simple and straight forward "Why isn't bluetooth working on elementary OS using the defaults?". The solution is complex and broad, but he nailed it. So yea, this shouldn't be closed. He should split this into the simple question and then the complex answer. – P.Brian.Mackey Jun 7 '17 at 17:20
  • Agree that @vmi should get answer credit; was frustrated that with the same problem. – lozadaOmr Jan 12 '18 at 15:35