Recently installed Elementary OS over my Ubuntu 16.04 LTS. Have been having a bit of trouble getting docker installed. Not much information out there.

Tried googling, and found a few hits such as https://gist.github.com/ChrisTimperley/17d5bf0276672367e86081fa74db4353, but nothing i've tried worked.

Any help would be appreciated.

3 Answers 3


Follow the instructions at Docker Store.

At the point where you add the dockerstore repository, you need to replace $(lsb_release -cs) with xenial.

 sudo add-apt-repository \
       "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
       $(lsb_release -cs) xenial \

@Tobias' answer is correct but is slightly outdated. Here's what you need to do:

  1. Find the base Ubuntu version using > lsb_release -a -u
  2. Copy the Codename from the output
  3. Replace $(lsb_release -cs) with the Codename

Eg: If codename is bionic

sudo add-apt-repository \ "deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable"

  1. Edit /etc/apt/sources.list and replace the Elementary OS version (loki, hera etc.) with the above Codename

Docker doesnt have specific install help page for elementary os , since its based on ubuntu follow this https://docs.docker.com/engine/install/ubuntu/ and Please use (lsb_release -ucs) instead of (lsb_release -cs) while adding docker repository in elementary OS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.