1

the bluetooth was functional just after Loki installed, but after run 'apt upgrade' bluetooth goes not work.

  1. press discover device gets nothing
  2. press "Bluetooth Settings" get below window bluetooth settings
  3. press the + button gets no respond. (was ok after os installed)

ken@element:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-05-05 10:42:39 CST; 2 days ago
     Docs: man:bluetoothd(8)
 Main PID: 1112 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─1112 /usr/lib/bluetooth/bluetoothd

May 08 09:30:14 element bluetoothd[1112]: Not enough free handles to register service
May 08 09:30:14 element bluetoothd[1112]: Not enough free handles to register service
May 08 09:30:14 element bluetoothd[1112]: Current Time Service could not be registered
May 08 09:30:14 element bluetoothd[1112]: gatt-time-server: Input/output error (5)
May 08 09:30:14 element bluetoothd[1112]: Not enough free handles to register service
May 08 09:30:14 element bluetoothd[1112]: Not enough free handles to register service
May 08 09:30:14 element bluetoothd[1112]: Sap driver initialization failed.
May 08 09:30:14 element bluetoothd[1112]: sap-server: Operation not permitted (1)
May 08 09:30:14 element bluetoothd[1112]: Endpoint registered: sender=:1.52 path=/MediaEndpoint/A2DPSource
May 08 09:30:14 element bluetoothd[1112]: Endpoint registered: sender=:1.52 path=/MediaEndpoint/A2DPSink
ken@element:~$ hciconfig
hci0:   Type: BR/EDR  Bus: USB
    BD Address: 4C:BB:58:DE:55:55  ACL MTU: 1022:8  SCO MTU: 183:5
    UP RUNNING PSCAN ISCAN 
    RX bytes:1304 acl:0 sco:0 events:86 errors:0
    TX bytes:3213 acl:0 sco:0 commands:86 errors:0

ken@element:~$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

$ lsusb; dmesg | egrep -i 'blue|firm'
Bus 001 Device 004: ID 0cf3:e005 Atheros Communications, Inc. 
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 14cd:8601 Super Top 
Bus 002 Device 002: ID 17ef:6025 Lenovo ThinkPad Travel Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[    0.174576] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    3.626421] Bluetooth: Core ver 2.21
[    3.626437] Bluetooth: HCI device and connection manager initialized
[    3.626441] Bluetooth: HCI socket layer initialized
[    3.626444] Bluetooth: L2CAP socket layer initialized
[    3.626451] Bluetooth: SCO socket layer initialized
[   14.824930] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.824932] Bluetooth: BNEP filters: protocol multicast
[   14.824937] Bluetooth: BNEP socket layer initialized
[   21.056354] Bluetooth: RFCOMM TTY layer initialized
[   21.056361] Bluetooth: RFCOMM socket layer initialized
[   21.056364] Bluetooth: RFCOMM ver 1.11

ken@element:~$ lsmod | grep 'ath3k|btusb'
ken@element:~$ lsmod | grep 'blue*'
bluetooth             557056  32 btrtl,btintel,bnep,btbcm,rfcomm,ath3k,btusb

11
  • seems related to upstream ubuntu bug 1490349.
    – user6308
    May 8 '17 at 4:55
  • Please edit the question to include terminal results for lsusb; dmesg | egrep -i 'blue|firm'
    – Jeremy31
    May 20 '17 at 17:43
  • just added,@Jeremy31
    – user6308
    May 26 '17 at 7:30
  • Check lsmod | grep 'ath3k|btusb' Does it show ath3k and btusb in the results?
    – Jeremy31
    May 26 '17 at 10:28
  • just added to question below. @Jeremy31
    – user6308
    May 31 '17 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.